Agreements are not created with Sign Link

May 12, Thu
Affected Service: Main Application Service
  • Investigating
    There is a problem with sending agreements.

    11:33, Oct 21 CEST
  • Resolved
    forgot to close this incident

    14:24, May 12 CEST
Back to current status